Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

iPad4 iTunes Error 4014. Already tried changing NAND.

  • Time
  • Show
Clear All
new posts

  • iPad4 iTunes Error 4014. Already tried changing NAND.

    This is another learning board that doesn't work. No prior work done. Board looks pristine. It is stuck in DFU mode and anytime i attempt to restore it, i get error 4014. I've been reading about the numerous error codes but for this one they only seem to describe cabling issues which this isn't. I've ruled out the battery, charging flex and changing leads and also tried restoring on different PC's. I've checked the main outputs of the PMIC which look normal.

    I found that iTunes makes a restore logfile and that gave me a little clue. It says that it was expecting Recovery Mode but found DFU, So for some reason it cannot get into Recovery Mode. My understanding is that DFU (aka device flash xxx?) is executed directly from firmware in the CPU?

    I read some maybe contradictory stuff on the internet that said Recovery Mode is run from NAND, or partially from NAND? I know i have tried turning on an iPad without a NAND before and it i couldn't get into Recovery Mode after that, but does really prove that NAND storage is used for Recovery Mode (as well as the OS)? I'm not sure i believe that. Then i read some more that sounded plausible, which said that when in DFU mode iTunes sends the iBoot loader to the device and the device places that in RAM, then Recovery Mode is executed... from ???. Now that sounds a bit better to me, but still doesn't explain where the hell Recovery gets loaded from? Maybe someone can help clarify all this.

    I felt i only had the NAND as a target to try and replace so I've done that, but needless to say it hasn't made any difference. I used an identical NAND from ALi Express that is pre-programmed with a new serial number so i think i can rule out the NAND as an issue. I checked that the NAND is getting power ok.

    After some more researching i stumbled across one person saying that the WIFI IC on one device caused 4014, but more interestingly i am seeing that aliexpress is selling RAM IC's for some apple devices stipulating they are for the 4014 error as well. I've checked already that the RAM IC's are getting their voltage rails (1.8v and 1.2v in the schematic).

    I'm seriously contemplating replacing the RAM IC's from another doner iPad4 i have because if the RAM is bad, then iBoot (sent from iTunes) won't be able to get loaded into RAM will it? Perhaps if this theory is true, it is then dumping back into DFU. However, if the RAM is bad, then how is DFU working? or does DFU mode not really use the main RAM so much?

    As you can tell i'm a stickler for knowing how things work. I wish there was more detailed information out there to learn from. Hopefully someone can help a little.

    Many thanks,
    Last edited by JMC; 02-12-2018, 08:08 PM.

  • #2
    When you pulled the nand did you check the pads at all?. As it's possible the nand is fine, it may just not be able to talk to the cpu as a line is out, short etc. As you've already taken the nand off before I'd pull that and compare to another board, just to rule that out. I'm presuming the nand is getting the 1.8v and 3v lines ok ?.


    • #3
      Hi yes i checked the pads and saw that it was getting all the voltages in the schematic, but it looks like a few of the lines for the NAND go under the CPU so i can't trace to see if there is a break there

      I don't know if this helps bu the iTunes / 3U Tools log sometimes said something about Baseband/BB ID couldn't be found. I will need to look back at the logs to find it again. This is just a WiFI only iPad though, would that be a problem?

      3U Tools also says error "Couldn't move from DFU to Recovery". It doesn't know what capacity the iPad is either but maybe thats normal when in DFU?

      EDIT: The iTunes baseband error:

      No baseband chipid reported. Will match Build Identity based on ap chipid and boardid only
      Last edited by JMC; 02-13-2018, 09:17 AM.


      • #4
        Im guessing it has no cellular hardware ?, as in the top cellular board, e.g it's not been converted as an iCloud unlock ?. If not you can ignore that error.

        you can check all pads using diode mode, the ones that go to the cpu should give a reading.