Announcement

Collapse

Announcement

Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: https://forum.ipadrehab.com/register to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

Iphone 6 possible long screw damage

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Jessa_the_Professa
    replied
    Oh heavens, you have long screw damage in middle and bottom right holes, probably also bottom left. That means this phone has had a lot of troubleshooting. An intermittent cell service problem in an iPhone 6 is often bb_cpu because that's the common fault. However, just follow rule number one and put the board in a known good housing and do a crisp visual exam to make sure all the antennas connectors on the board are not damaged. After that, I'd reball the bb_cpu if you want to put time into it.

    Leave a comment:


  • eDigitCom
    replied
    Thought the IMEI and firmware are showing up in Settings > about the IMEI does not appear on the display when typing on the keypad the code *#06# -- Strange ??

    Leave a comment:


  • eDigitCom
    replied
    Thanks crea2k and Sly

    I checked for the firmware and the IMEI number and both there

    Interesting crea2k I did not think there was a second antenna for the mobile newoirk

    Could you send me an image of exactly where is on the phone Would appreciate it

    I beginning to start looking at a video Jessa made about this problem. Been busy so only so far got to 15 minutes into it. She was covering the iPhone 6/6s and at the start she speaks about the 6s where she checks for the firmware and IMEI and if present she was leading to two pads that were a common issue unter the BB_CPU

    Sly The first think I did test was a know good Antenna which is on the Charging port itself and yes it came up for me also for a short period of time. So has said above was thinking when this occurred would it give you some idea what was causing the problem

    I think you are writing about what Jessa said about these two pads under the BB_CPU. This was for a 6s. I did not get has far into the video yet to see if it was the same for the 6


    I think you begin to look more had Jessa videos when you get an issue yourself which is the same has she is teaching

    I be interested to know if Jessa thinks it is screw damage?? She would know immediatly

    Only working on the logic boards for 6 months so it takes a period to get up to speed on how thinks work and what to look for. This comes with time , theory and putting the theory into action

    My big fall down at this stage is the microsoldering Never hardly solder before not alone microsoldering so at this stage I not be up to the standard of removing the BB_CPU, repairing the pads and then replacing the IC

    ​​​​​​​I wish I was has would love to solve it but also get great satisfaction if I repaired it

    Here is a link to Jessa video on this issue Thanks for help

    Want to train with us? Come to our in-person only Practical Board Repair School in Rochester NYNeed data recovery? Contact us at: ipadrehab.comClick to ope...






    Leave a comment:


  • Sly
    replied
    Middle screw hole does look screw damaged. Not sure if there are reception trace there. Zxw has some of those traces mapped out

    Leave a comment:


  • Sly
    replied
    We don't work so much on reception problems so much at our shop just yet. I can tell you that in the past I have replaced the charge port flex with the antenna a couple of time and had reception back for a little bit, but it would always drop after a few hrs or days. I think that it is a broken pad connection under an IC, and by replacing the port it applies pressure to the board replacing the contraction until the board regains it's natural shape.

    Leave a comment:


  • crea2k
    replied
    Make sure the screw at the top of the phone is also screwed in properly and the metal insert is touching the board contact as the phone has a top and a bottom antenna, not just one. Its possible that one of the ics for a certain signal band is broken too. E.g you turn the phone on and the first band it picks up is 2g, it works fine on that, then maybe sees that 4g is available and switches over to that and looses signal as some 4g hardware is broken. To rule this out go into settings and turn off 3g / 4g / data etc. Im not sure if you can specifically turn off 3g any more, but you can take a look. Also when it goes searching no service check in settings, general, about too see if the baseband firmware is present, that way you can see if its the BB_cpu flunking out or something signal area related. Also you can try comparing diode mode measurements around bb_cpu and bb_pmic to a good board or to the diode map that Mohammid posted the other day.

    Leave a comment:


  • eDigitCom
    started a topic Iphone 6 possible long screw damage

    Iphone 6 possible long screw damage

    An iPhone 6 came to me with searching no service

    I replaced the charging port with an know good one to see if the network antenna may have been at fault

    On replacement the mobile network came up but approx an hour later it started the searching and no service procedure again.

    By doing this would it give some idea where the fault is?? and why did it stop the searching and no service for a short period if the fault is else where??

    On further investing after removing the screen I noticed one of the screws was missing


    I attach an image of the screw holder

    Is this screw damage ?? and if so would it cause the no searching and no services issue


    Thanks






    On futher
Working...
X