Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

iPhone 5S - No Boot

  • Filter
  • Time
  • Show
Clear All
new posts

  • iPhone 5S - No Boot

    This particular device has an unknown history, supplied to me, with a new tristar, with screen off.

    So before touching anything, when I removed the board the shield was bent, a coil was chipped under it, but as far as I can tell, they may never have even gotten the shield off.
    It looks like they were trying to remove it with a soldering iron and brute force.
    No sign of anything being touched at all, apart from the chipped coil.
    No other sign of damage.

    The battery was dead (literally 0v potential)
    Testing without the battery, I had a fluctuating ~0 to ~20mA through USB
    Connecting power direct to where battery goes I also had the identical fluctuation in power after plugging in USB, with no draw prior.
    Nothing pointed to Tristar, but since I had one and it was quick I did swap it, but as expected, nothing changed.

    I then actually tried diagnosing it and every rail leaving the power management IC is turning on and off.
    The first rail I care about is PP1V1_CPU, which is producing for 150ms (see scope image), remaining off for 550ms, then repeating.
    Not just that 1 rail, every rail I tested was doing the same. For example, PP3V0 had the same time intervals.

    PP_VCC_MAIN is perfect 4.0v during this testing.

    Not sure where to go from here.


  • #2
    The history is a little unclear—how
    could someone have changed tristar without removing the shield?

    When the pmic is resetting, there is a reason why—some sort of data line communication somewhere. The only one I’ve ever solved in this state ended up being i2c1 communication causing reset.

    I would start with update/restore to rule out software.


    • #3
      Thanks for your time Jessa.

      The Tristar was provided on reel, not already replaced, I replaced it.
      Sorry for making that unclear.

      The phone only remains powered for 150ms, not enough time to do anything with software like a restore (that I am aware of, please correct me if wrong!)

      I don't have a known good 5s, so I am going to get one of those and start digging deeper.

      I just posted this in another unrelated thread, but this is the current draw (100ms, 50mA divisions)
      If I solve this I'll post all my findings.


      • Jessa_the_Professa
        Jessa_the_Professa commented
        Editing a comment
        I would start with software update/restore. Are you saying that you also have the PMIC resetting phenomenon occuring when the phone is in recovery or DFU mode? I'd be really surprised if that is the case. Boot the phone to DFU mode and attempt to restore.

    • #4
      Well, that made me find something else wrong...
      I don't know if I ever tried boot from power button, only boot from usb.
      anyway, it didn't work.
      I began looking into why and PP1V8_ALWAYS is 3.64v. It is constant, and very stable.
      VCC is exactly 4.00v, so its not a vcc short.

      I can't see any external components which could pull up that line.

      More on this, the power button in the frame does not connect to gnd when pressed.
      I would assume this to be how it works. All the other buttons work as I would have expected.

      I am sorry if these questions seem....dumb. I don't generally work on phones, and this is my first 5S I've opened.


      • #5
        Well pp1v8 always should be 1v8 for sure. pp1v8 always is a pmic output. I've never seen any of the pmic resetting phones actually be a pmic fault, but generating pp1v8 always from main is a core function of the pmic and it would probably be worth ruling out bad pmic on this device assuming that resistance of 1v8 always matches a known good. This is striking a chord of pattern recognition in the vault of my brain which is a messy room with papers everywhere. I think there are some folks on gsm forum who once discussed 1v8 in an iphone 5 and some resistor near cpu going bad---implying that on that 1v8 the resistor is pulling the line to 1v8. I know there are some resistors on the 1v8always line on the 5s, so i'd check them out and consider replacing because it is easy just to rule all that out before changing pmic. The 5s pmic is not underfilled, so it is a doable job with basic microbga experience.


        • ku7
          ku7 commented
          Editing a comment
          I haven't had much more luck yet, but I am going to be getting hold of a known good (only smashed screen) 5s mid week, and will use that to further diagnose, and maybe as a donor board after taking plenty of readings for things like the resistors and pmic.

          I will let you know what I find if I do succeed.

          Thanks again!

      • #6
        I should have taken more notice of the bent shield.

        i know my camera is really bad, but that's cracked balls under the PMIC.
        I'm going to swap it out and hope this is the only damage remaining.

        For the record, the only rails having issues are the end of the PMIC I can't see under.


        • #7
          You can try pressing on pmic to see if you get a change before swapping it


          • #8
            I know this has been forever, I threw it in a pile and ignored it for some time.

            pulled pmic off, reballed it, nothing at all
            as in, pp1v8_always was 0v

            i swapped pmic and again, nothing.
            pulled pmic and I have a find the link between the pp1v8_always and near the connector it’s fine.
            i placed pmic back, and oddly enough it booted fine!!!!

            did full data recovery.

            Put it back in the case, and it’s dead again.

            end of this story is I have no real idea what was wrong .

            I honestly suspect it was pcb damage, but could have been some unintentional side effect of heating the board so many times, and I might have been off target the whole time....

            thanks for your help on this!


            • Jessa_the_Professa
              Jessa_the_Professa commented
              Editing a comment
              glad you got the data--thanks for the update!