Announcement

Collapse

Announcement

Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: http://forum.mendonipadrehab.com/register to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

iPhone 6 Logic Board faulty due to swollen battery

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • iPhone 6 Logic Board faulty due to swollen battery


    iPhone 6 Logic Board faulty due to swollen battery


    Receive an iPhone 6 with a swollen battery with the screen lifted

    On examining and fault finding the phone it came down to the logic board
    The charging current went only to 0.07 and when connected to a DPC the image came up showing a current of 0.25 V. The image then went but the backlight remained on for a very short period after with the current at a steady value of 0.16V. The current then dropped to zero volts

    The below link shows a video how I went about trying to track the fault

    https://www.youtube.com/watch?v=NN5MI4BKk-Q

    I have now got to the stage where I have to ask for advice on how to procedure further in locating the fault

    Thanks


  • #2
    Are you sure the bad battery / possible constant reboots hasn't caused software corruption ?. Have you tried putting it into dfu mode and restoring with a new battery ?.

    Comment


    • #3
      I didn't watch the video, but from your description, this sounds MOST LIKELY like software corruption from bad battery data lines. What you describe is the normal behavior of a phone that is autobooting to DFU mode because it doesn't know what to do--instructions are corrupted. I would change tristar just as a matter of housekeeping and then restore and see what happens.

      Comment


      • #4
        Thanks Jessa_the_Professa and crea2k for your help


        Sorry about the delay in replying

        Yes, it turned out to be a software issue

        I first put it into DFU mode and connected it to iTunes on my PC. Was told it needed to be restore which I tried but I did not have any success has there was an issue on that computer with iTunes (missing some file) Same think when I re-installed iTunes.


        I then switched to a Mac and it went straight into recovery mode However on trying to restore it gave this error 9 which I believe is an issue with the NAND


        I then put slight pressure on the logic board and tried to restore it again and bingo it restored

        More then likely the NAND needs reballling

        On bringing the iPhone up it is iCloud locked and the customer could not remember the password and did not know the password to access the email address to reset the password

        Apple also have a recovery mode where you give them you contact phone number and they say they would get back to you with instruction how to get your Apple ID password. I not hear from them so far and it is now approx. a week. I would think more likely they will not


        One other thing I noticed when typing in the customers Apple ID it needed the number six but was unable to type it. The screen used is a know good one so not a issue with the screen


        I attach image where I try to type the number six but it only typed the numbers five or seven next to it. Same issue with the letter Y, g and v


        I tried even two more know good screens and it was exactly the same

        Anyone come across this issue and if so where they able find out the reason that is causing it-- Maybe incorrect instructions from the CPU cause by corrupt software in the NAND??


        Thanks Jerry
        Last edited by eDigitCom; 04-26-2018, 11:43 AM.

        Comment


        • #5
          I would diagnose it by probing around the areas that control touch. Try to compare with diode mode to what is in zxw tool, or better yet to a known good board. With the battery sweelling, it could have cause flex on the board the lifted some chips from the board.

          Comment


          • #6
            It turned out to be iCloud locked by the customer and they cannot remainder the details So cannot do any more test

            All the touch was good except the number 6 and the letters Y , G and v. Could a touch issue cause just one number and 3 letters not to work?? or even one letter or number has i remainder a while back that one letter would not type on the left hand edge of the screen keyboard on another iPhone and had a know good screen fitted to it

            Comment


            • #7
              You have a dead line of touch. This is either a problem at the connector, dirt/bent pin or a problem under one of the touch ics, probably meson. If you had drop that made NAND get a cold joint, then you that same drop could also make a cold joint under meson. I glanced at your video above---connectors have significant dirt in them, so unless you cleaned that then this is your MOST LIKELY reason.

              Look at the schematic for touch system. Predict what would happen if you simply deleted one of the pins in the touch connector.

              Comment


              • #8
                I check this out Jessa thanks

                Comment


                • #9
                  If one deleted then you not be receiving the correct data ??

                  SAGE_TO_TOUCH_VSTM_OUT <
                  0 --- 23)

                  24 data lines needed
                  Last edited by eDigitCom; 05-09-2018, 04:43 PM.

                  Comment


                  • Jessa_the_Professa
                    Jessa_the_Professa commented
                    Editing a comment
                    predict what the exact failure would MOST LIKELY be---I'll make it multiple choice.
                    A. Phone won't boot
                    B. Phone will boot but front cameras will not work
                    C. Phone will boot but touch system will not work at all
                    D. Phone will boot but you will have a dead line of touch on the screen.

                • #10
                  I go for C

                  Reason on thinking about it you be receiving the incorrect data every time if a line was missing

                  Comment


                  • #11
                    If one line deleted I am thinking how would the same spot on the screen not work??? There are 24 lines so if one is deleted - for the same spot of the screen not to work the same information would want to be received from the CPU every time. Each touch of the screen it would receive different information and this information would not be correct because of the line that is missing. So all the touch would
                    not work in this case??

                    This my logic approach to if one line is deleted ????


                    Comment


                    • Jessa_the_Professa
                      Jessa_the_Professa commented
                      Editing a comment
                      I have asked this same question to dozens of students and they always guess "dead line of touch" which would be my guess as well. There is no right or wrong, we are all just guessing. I'm pointing this out just to highlight that your logic here is unusually different than most people. My guess is that because each of these data lines appears to be very similar to others (look at the names of the lines of the connector pins, many are the same) that what each one does individually is form part of grid of information collecting for touch.

                      From the iPhone 5s where touch problems were common due to connector damage we know that some of the connector lines are required for overall touch, but most of them correspond to a single vertical line of touch on the screen, i.e. the spot where the number 6 is on the display.

                      Single line of touch being out or ghosting is going to be connector or meson/sage or cumulus.

                  • #12
                    A touch system I believe is designed in a grid system Not know much about them and when pressing the screen a capacitor greates a voltage
                    witch can be a high or a low (1 or 0)


                    So maybe I am incorrect but I am looking at the lines SAGE_TO_TOUCH_VSTM_OUT <
                    0 --- 23) has been given a different pattern of 1 and 0 for each grid. SAGE_TO_TOUCH_VSTM_OUT have the same name
                    but all different has each given a 0 to 23

                    so this makes each line different from each other?? Also TOUCH_TO_SAGE_SENSE_IN
                    have the same name but different from each other by having a 0 to 11 (12 bits)

                    So each grid will have at particular pattern of 1's and 0's for it to work and if this pattern is not correct it will not work


                    So for example the number 6 on this grid has a pattern of 0110 taken just 4 bits so we now have a grid
                    of 16 (4^2) AGE_TO_TOUCH_VSTM_OUT <
                    0 --- 3)

                    Now if we say line zero is deleted this will cause a hight (1) has open circuit. Now for the number 6
                    we have a pattern of 0111 = 7 which is not correct so will cause a 7 on the scream instead of the 6?? The touch works but displays a different number the one at each side of it


                    Now take another number on the grid say 8. Its correct bit pattern is say 1000, Again bit zero is deleted gives a high(1)
                    now the number 8 has a pattern of
                    1001 = 9 . 9 displayed on the screen instead of an 8??

                    Again not correct looking at it this way then more then the number 6 will be affected on the grid

                    Any bit pattern with a high on the zero bit will work OK. The number 7 should work (0111) Maybe a corrupt bit instead of a deleted line????

                    One way I suppose of finding out is disconnect a line and see what happens
                    Last edited by eDigitCom; 05-20-2018, 12:51 PM.

                    Comment


                    • #13
                      Yer that's pretty much correct as if you've ever not soldered one of the lines on a iPad mini digitiser connector you get crazy touch so I'm guessing part of the grid is missing.

                      Comment

                      Working...
                      X