Announcement

Collapse

Announcement

Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: http://forum.mendonipadrehab.com/register to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

iPod 5 Data recovery/repair for functionality

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • iPod 5 Data recovery/repair for functionality

    Hello everyone,
    I don't have much experience with iPod motherboards. I'm trying to get data off this one, and repair it as a usable device if possible.

    This originally came in as a battery replacement requested by the customer, but the battery is not the problem.

    When we plug it to charge it draws 0.50A right away, with the battery unplugged. With the Power supply it was draw 0.600A as soon as I request it to boot.

    I'm suspecting a short in the one of the main power rails, and I'm about to go and start going through the schematic and see if I can find the problem. I'm pressed for time, and the customer is not from town. I've decided to turn to the repair community in hopes that some of you might have troubleshooted iPod boards before, and might have some sort of guidance or known common issues to look for to help accelerate this repair process.

    I'll update this post when I have more information about the device.

    So far Diode Mode from Positive to Negative terminal of where the battery connects reads at 0.994V, and the from Negative to Positive reads at 0.424V which compares to known good board.

    From past experience when VCC_Main is shorted it will usually bring down the Positive to negative diode mode measurement to a lower value, so I don't think it's a VCC_main issue...So far anyways (Might not apply to iPods)

    Thank you

  • #2
    Ok, so by trying to boot the device with the power supply, it was generating a lot of heat at what I believe to be the PMIC for the iPod 5 touch.
    I used freeze spray, and the frost of the PMIC is melting fairly fast. I don't think this is actually a PMIC issue. I started to probe around with my multi-meter, and found this cap to be shorted to ground.

    Now, my big issue with this is that I have access to the schematic, but not the boardview; therefore, I have no idea, as it stands, of which (assuming power rail) this is and how much voltage I can safely inject in there to find where the short is actually located.

    Attached Files

    Comment


    • #3
      Sorry wrong cap. this is the correct one. I've also found an other one.


      I've tried only injecting 1V in the cap on the side that has a slightly higher resistance (figured it must not be the ground side) and the first thing that melts is a spot in the PMIC, which is the same general spot that was melting first when I was booting the iPod from the PS.
      Attached Files

      Comment


      • #4
        So upon closer look, I've noticed that the first first to melt as far as I could see was actually a coil under the frame for the shield.

        Doing this has relieved the short of the caps I was first looking at first. The bottom part of this is still shorted to ground, but the top part was connected to the caps.
        The PMIC does still have a spot that melts first, as far as I can see, but I don't want to call PMIC prematurely.

        Not having a boardview to know what line I'm actually working on is making this very difficult.
        Attached Files

        Comment


        • #5
          Well, I've probed around a little bit, and so far I have not found any other component connected to the bottom connection. I've also looked at the PMIC set up in the schematic (without following every lines that went to other sections) and all the inductors I see connected to the PMIC has one side going straight to it.

          So I'm thinking more, and more that the PMIC is at fault here.
          That's it for tonight on this.
          I'll sleep on it, hopefully someone might have some insight.

          Thx!

          Comment


          • #6
            If this is data recovery I would inject 3v-3v3 into that line on the not short side before prompt to boot and then attach a screen and cross my fingers. In many devices a 3v line fails internal to the pmic. No one works on iPod 5 for board repair and there is no experience base particular to that device. If you have a known good then just swap pmic

            Comment


            • #7
              Thank you for the advice Jessa,
              I've check with my known good iPod 5 and that line was a 1.8V. We were able to retrieve over 1000 baby and family pictures, me and the client were both very happy. Thank you for your help!
              Attached Files

              Comment


              • #8
                Great job!

                Comment

                Working...
                X