Announcement

Collapse

Announcement

Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: https://forum.ipadrehab.com/register to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

iPhone 7 plus received for a screen replacement

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Just do a backup first, then afterwards restore from backup. I'm quite sure this is the issue as I've seen this before and the only way I got the fingerprint sensor back was a full restore from DFU mode.



    The above comment I did not make How did it get there??
    Last edited by eDigitCom; 07-17-2018, 12:13 PM.

    Comment


    • Jessa_the_Professa
      Jessa_the_Professa commented
      Editing a comment
      The comment that you are referencing appears to just be an answer to your post by John (below), or he may have made the same post as a comment. Perhaps he deleted an answer and that answer was one that you commented on, in which case your comment would also be deleted. No need for alarm. Everyone is friendly here. John makes a great point reminding us all that home buttons do not like to be swapped for restore or update operations.

  • #17
    Just do a backup first. Make sure you also back up the apps. https://www.hongkiat.com/blog/backup-restore-iphone/ Then do the DFU restore. I feel strongly this is the problem as I have seen the exact issue arise and the only way to get the fingerprint back was a restore.

    Comment


    • #18
      Not sure what it happing with the comments I not make the last comment that is under by section. Also the comment I made has been deleted where I said I not do a restore has this would delete all the customers data and if I did that I be in real trouble

      how this happen ??? There is commend above I not make and the comment I did has been deletrfed
      Last edited by eDigitCom; 07-17-2018, 06:16 PM.

      Comment


      • #19
        Jessa_the_Professa I already replied to @join I"I know what is going on here. You did a restore"

        but my comment was deleted???? In my deleted comment I said I "no way did I do a restore and would not do a restore"

        I also did not make the comments in my comments section above??? For this to happen my comment deleted and a comment put in my comment section is not great

        How could this happen?? Has this can and cause all types off confusion which in this case has??




        NO RESTORE WAS DONE ON THE PHONE THE BOTTOM LINE
        Last edited by eDigitCom; 07-17-2018, 12:26 PM.

        Comment


        • Jessa_the_Professa
          Jessa_the_Professa commented
          Editing a comment
          Okay, you didn't restore. Did you update? That is the same thing.

        • eDigitCom
          eDigitCom commented
          Editing a comment
          Yes I did do an update

      • #20
        This is the state of the phone at present where no restore took place I allready made this statement also

        __________________________________________________ _________

        Jessa now get more weird


        I got the customer to try and see if the touch finger print she created worked for her and she had no problem getting access to the phone by her finger??

        However trying to create a new touch ID it fails ???

        The touch id must be working has the customer can get access to it??


        I going to get another screen from another supplier and see if makes a difference??


        Thanks Jessa for taking the time to give me advice on this especially since you are off on a vacation

        Comment


        • #21
          Tested a new screen from another supplier and the same issue cannot create a new fingerprint ID. The once created by the customer works fine

          Comment


          • #22
            Next I take a diode reading of the J1 connector on the button flex See if anything shows up on that

            Comment


            • #23
              I understand that you did not restore, but did you update? That would have the same effect. I agree with John---make a full backup and then try a DFU restore. Right now because you've ruled out hardware problems, the MOST LIKELY problem here is a software problem that occured as a result of troubleshooting a hardware problem.

              Comment


              • #24
                OK Jessa will do

                Thank you

                I did an update OK

                You told me to to do a Hard Reset which I did also
                Last edited by eDigitCom; 07-19-2018, 08:23 AM.

                Comment


                • Jessa_the_Professa
                  Jessa_the_Professa commented
                  Editing a comment
                  When did you do an update----was it an update with the bad screen? If so, that is the same as restore and the cause of the problem.

                • eDigitCom
                  eDigitCom commented
                  Editing a comment
                  It was Jessa
                  I pointed this out in my first message I updated thinking that this might solve the problem but has you said had the opposite effect

                  Why in this case is an update the same has a restore and unable to create a the Finger Print ID
                  Last edited by eDigitCom; 07-22-2018, 06:36 PM.

              • #25
                Doing the DFU solved the issue the finger print works fine Thanks very much to John and Jessa

                Why does an update or restore cause this issue if you do it with a fault on the phone

                I think you will know if this is the case if on power-up if you not receive the error "you cannot active the touch id) If this message appears then you have a hardware issue

                Now another issue occurred

                After returning the phone to the customer she contacted me that the phoned turned off and putting the charging cable on it it loops on the apple logo

                When repairing the phone this happened to me also after connecting the Proximity cable to the logic board When I removed the cable it power up OK Once connected back again was fine so I thought it was some glitch in the software

                Now it seems not


                Now thinking that maybe an issue with the camera itself The screen around was this area very badly damaged

                Would a bad FCAM cause such an error to accrue??


                Thanks

                Jerry

                Comment


                • #26
                  I was sure this was your problem, don’t understand the fear of a backup and DFU restore as stated earlier.

                  Comment


                  • #27
                    Thank you very much John Really appreciate your help

                    I felt you should not do a DFU until you are sure you have eliminated all hardware issues


                    Would you have any idea John what would be causing the problem it is now having

                    Comment


                    • #28
                      I’m assuming you checked for connector damage on both ends and tried another camera assembly from a parts phone (never use those aftermarket ones as they are all junk). If it’s not that I’d start by probing the board connector and checking against a good board values. If you don’t have that you can use zxw values but in my experience they are off quite a bit and could lead you down the wrong path.

                      Comment


                      • #29
                        Restore (and update) are always a last resort for folks working in our field. We deal primarily with hardware problems—phones that have been dropped, water
                        damaged, bent etc. The internet overwhelmingly prescribes restore as a cure all tonic and first step of troubleshooting because it is easy for DIY folks and it can cure software problems in phones that have no hardware problems.

                        But you can’t fix a hardware problem with a software solution.

                        If you have a phone that has a hardware problem, then asking it to restore or update is asking for trouble. The phone may end up nonfunctional and you will have lost clues that you rely on. Take audio ic for example. A phone with audio ic problem will have greyed voice memos and that’s a big clue. Ask it to restore and it will be error 4013 and in recovery mode and will not boot at all—a phone like that is much harder to figure out.

                        remember that restore and update do a system check on many systems that could have a problem that no one cares about—like Apple Pay. If you had left the phone alone it would have worked fine just with no Apple Pay. But asking it to restore means that it will never boot again because it can’t pass update/restore. If a phone has any suspicion of hardware problems rule those out before doing update/restore.

                        here in this very case we see another example. This phone had a common hardware problem—bad screen. Changing the screen and the phone would have booted up as normal was the only thing it needed. But we got into several days of panic and troubleshooting because it was asked to update when there was no chance of software problem.

                        all that is solved and we learned that update/restore is an important and necessary tool but one to use judiciously.

                        why is it boot looping now? All repairs start with rule #1.

                        Comment


                        • #30
                          I will have the phone back on Wednesday to check Jessa

                          I think maybe the fcam assemble but will have to check

                          The reason I pointing it this area as this happened to me at one stage and when i disconnected the fcam cable frrom the logic board it came back up agaiin


                          Thanks very much for the detail information about

                          In this area you are genius and one of the best teachers i have come across

                          Thank you

                          Comment

                          Working...
                          X