Announcement

Collapse

Announcement

Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: http://forum.mendonipadrehab.com/register to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

iPhone 6+ keeps rebooting after 2 minutes or when trying to backup to computer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • iPhone 6+ keeps rebooting after 2 minutes or when trying to backup to computer

    Ok, this is a strange one.... This phone was brought in because it was bent backwards pretty bad and no touch after a drop.

    After doing my normal checks before diving into soldering, I concluded M1 jumper failure or chestnut causing the no touch. After completing the M1 jumper, and putting on a new Meson, the phone still had no touch. I double checked everything I could in diode mode and it appeared the IC was setting properly. No excessive movement when it seated.

    I moved on to Chestnut as I have seen it cause "no touch" issues. I replaced chestnut and still no touch. I then proceeded back to Meson and replaced the it with another one.

    This is when everything went strange.... Right side backlight stopped working and touch began working. I checked the connector in diode mode and verified the driver seemed to have become disconnected from the heat, so I pulled it and put a new one on. Then.. No image, no backlight and no DFU / Recovery. I pulled the driver again and put on a new one which brought back the backlight and touch was still working.

    Now for the problem I have now.... The phone will not stay on with the computer connected for data backup. When iTunes begins the data backup to the computer, the phone will reset after 10 seconds. I have tried with both battery and DCPS. No change. Sometimes the screen will become all distorted and fade out before it resets. Without the computer hooked up, the phone will stay on for around 5 minutes with the screen "On" and will sometimes shut off the LCD but the backlight still works, or the screen will distort and fade out then the phone resets.

    I have not touched Tristar yet as this board has been through a lot already and the AP lines to tristar that I can test seem to be ok in diode mode against a known good board. The only thing I see off is the diode mode reading on J2019-32 (Reading 593, should be 650) and J2019-34 (Reading OL, should read 1475). This reading I got before starting any soldering on the board. After replacing Meson both times, I still got the same reading, and I checked it again when I replaced chestnut. I have seen OL before and could usually nudge chestnut and it would start registering correctly in diode mode. Nudging did not work and replacing chestnut again did not work. While chestnut was off the second time, I checked in continuity mode between the connector and E2/E3 under chestnut. Full continuity throughout the whole line (even to back of board, tested at C2409).

    Cameras are not working either (Possibly LDO, but have not checked yet)

    Any ideas why this phone keeps rebooting?

  • #2
    Here are my comments on this Repair.

    Is the phone with you for data recovery?
    if so then always be eliminating variables every time you put heat on a board, never adding them.
    From the beginning—which is causing no touch, chestnut or meson? This is easily determined in a few seconds with a multimeter—look at chestnut on the schematic (not zxw). What does chestnut do? What are it’s outputs? How could we measure them?

    You would have found that chestnut voltages were present, and also found that there is no similarly feasible way to test meson since it is a data chip not a power chip. So we have to put heat on the board to replace meson, it’s unavoidable.

    Since you still had no touch, you could have concluded that meson placement must be bad after verifying chestnut outputs again with a multimeter. You would have not been trolled by the OL reading on PN5v7 at the connector because you would have seen that PN5v7 was indeed present. For that pin, think about how high the “normal” reading is 1.4 compared to all other diode mode readings. Some small variation in multimeter can easily turn 1.4 into OL at that pin.

    The point is that with a multimeter and a voltage test for chestnut we could avoided most of the problems you created on this board so far and the variables that you introduced from too much heat.

    Because of the technician introduced variables this case is now complex. We have had a lot of heat and likely “nudging” that involve chips on difficult to measure data lines and we know because cameras are missing that we have had overheating damage on the top of the board.

    Are those variables responsible for the rebooting? Or is it something native from the bend? This is a muddy picture.

    the first thing I would do is see if I could raise the current limit on my dcps, and see if I get a current spike when the phone reboots, if so, I’d try to keep the board cool so I could at least get some of their latest pictures via 3utools.

    id spend significant time attempting to get data as it is now before putting more heat on the board. If I had to go back to the board I’d remove variables such as bl driver, and I’d read the real time log in 3utools if I could to look for clues about what was going on when it dropped.

    Comment


    • #3
      Thank you for getting back with me! The cameras were not working several months before after the customer dropped it the first time. The customer was hoping to not have to get a new phone, but at this point. it looks like they may need one.

      The phone had been having gray flicker before the customer brought it in (Should have mentioned in first post...) which we could not get to happen here during testing as it looks like it was completely separated from the M1 pad. When I pulled Meson up, M1 pad came with it. This is why I pulled Meson first.

      For testing purposes, I tested 3 other boards at J2019-34 and my meter easily reads 1450 - 1468 in diode mode.... This board reads OL, but if it is my meter, I guess I will go with that.

      The only IC / Component that I nudged accidentally was U1503, but I pulled it up, reballed, and reseated it. It looks connected well and the pads under were in good condition. This was done during chestnut replacement. I checked each point around the IC to ensure there were no shorts and diode mode readings were the same as a working board. I even did a capacitance check for the hell of it.... Same between the boards.

      I will have to see what I can do with 3uTools... Not messed with logging on it before.

      Comment


      • #4
        I can't keep the phone connected long enough to do anything with it. When 3U does read the phone, it stays connected long enough to pull the splash screen with all the info, then that is when the LCD goes distorted and the phone resets.

        Comment


        • #5
          Re: OL reading on PN5v7–what is the purpose of PN5v7?

          if you had grey flickering bars this could NEVER be chestnut. I’m focusing on this because this is the second phone that you messed with chestnut on where it was not a chestnut problem. The first one happened to resolve so you’ve become convinced that chestnut is a routine failure point for touch disease—it is not. Chestnut gets water damaged but it is not a native failure point for touch disease, it can only become problematic by technician overheating and even that is rare. I want for you to learn to measure chestnut outputs before putting heat on chestnut and I want you to look at the schematic and have a good understanding of what it does.

          Did you set your dcps current limit high and try to keep the board cool when connecting to dcps? Is it dropping because it is hot (current spiking before drop) or is it dropping because it is missing data—current low then drop. If the latter try putting pressure on cpu.

          Comment


          • #6
            I did set the DCPS to 3A and tried that, and even set it to 4A, but still kept disconnecting. The amperage sits around 0.12 to 0.34 while connecting to the computer. When it resets, the draw instantly goes to 0.00. There does not seem to be a spike before then. I am using a copper block on the CPU to help draw the heat away from the board.

            Yes, I know the flickering is not caused by chestnut issues. I do know that no display or no touch can be caused by chestnut, but M1 is the most common cause. After replacing Meson 2 times and no touch, I checked chestnut which is another possible route as J2019-34 was reading low and the only IC connection points are chestnut and meson.

            So, I have since removed both backlight drivers and removed chestnut again and have attempted to recover the data once again. The device still reboots when trying to pull any data from the phone, but now it does pick up much quicker on the computer than it did before. It was taking about 30 seconds to register on the computer, but now it instantly registers. The USB connection sound when connecting the device does sound 2 times instead of 1. Almost like the phone resets the USB connection for a split second.

            I also noticed that the battery percent shows 1% most of the time, and sometimes will show 21%, 56%, 100%, and 16%.... all running from the DCPS or battery. Does not change when holding pressure on connector.

            Putting pressure on the CPU does not change anything either I held it for the full 2 minutes before it it rebooted again automatically. Tried 2 times with different pressure and still the same result.

            Could this be a damaged tristar?

            Comment


            • Jessa_the_Professa
              Jessa_the_Professa commented
              Editing a comment
              It sounds more likely that you have a problem at the battery connector. A phone will reboot whenever it can't understand the battery _SWI line. It is possible that your problem is anywhere on SWI, such as tigris, but since that would require a completely independent fault to have simultaneously occurred at the same time as classic touch disease, the MOST LIKELY problem is that you have a connection problem at battery connector. If for some reason you took the bottom shield off (which should not be the case) then it would point to battery connector even more. As it is, the bottom half of the phone should have never seen heat, so either battery connector or tigris are possiblities. Usually if I am changing tigris i also change tristar since tigris can't get damaged without tristar damage.

              Re: chestnut. To be clear there is NO POSSIBLE way that you had a problem at chestnut on this phone. Flickering lines = M1. If you have no touch, then your meson chip or placement MUST have been bad. If you are low on a diode mode reading that goes to meson, right after you placed meson and had no touch---then the problem is meson. I have watched students have to place meson three or four times--each time bridging a 5v7 line under meson. I have seen strips of mesons coming out of china where 8 out of 10 mesons will have internal shorts and all be reballed crap.

          • #7
            I did catch myself checking the battery connector for bad solder joints, bent connections, etc... but found nothing The no touch issue was resolved on this phone as it was a problem with 2 of the 3 Meson IC's and I ended up reballing their original one and reinstalling it which fixed the touch issue. I also found that my thermistor on my hot air station was reading over 50 degrees F lower than it was actually putting out.... on an Aoyue 738H. I have since replaced the station and believe a lot of my problems were happening because it was hotter than it should have been. Since this post, I have done at least 7 more touch IC repairs with no issues.

            I did not pull any shields off until Meson was installed 2 times and still no touch. That is when chestnut was checked and then back to meson. After that, I believe the extra temperature from the hot air caused components on the other side to come loose due to that goo Apple puts on some of their components?...

            I do know that flickering lines means M1 and there are no other possible ways for flickering lines to happen... I hardly ever have to redo meson more than 1 time but I guess this was one of those times...lol.

            I just find it strange that the this phone came in bent backwards severely and only touch IC was the only issue.....

            Comment

            Working...
            X