Announcement

Collapse

Announcement

Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: http://forum.mendonipadrehab.com/register to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

DEAD Iphone 8 Plus Shorted PP_PP3V0_NAND SOLVED but has secondary issue.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • DEAD Iphone 8 Plus Shorted PP_PP3V0_NAND SOLVED but has secondary issue.

    Had a hard time logging in to post today.. so ended posting this on Intro group, but now I am in. So here is my Re-Post



    Yesterday I resolved an iPhone 8 plus no boot/no power.

    SYMPTOMS / HISTORY:
    The battery was 0v dead. I used a known good battery but still does not power.
    When plugged into a PC it would connect, disconnect, connect, disconnect repeatedly. History was that it was dropped hard on the corner, however, the housing and the screen did not sustain any damages. I assume it must have been in a good case. DCPS was 0.00v before prompt to boot. DCPS jumped to 1.30a and back to 0.00 and then jumped again to 1.30a and then 0 repeatedly after prompt to boot.

    FAULT FOUND:
    I found a short on PP3V0_NAND. Capacitor C2650 was shorted to ground, Removed it and relieved the short and left it off. The device than powered up to the home screen, I thought the job was solved and done,

    SECONDARY ISSUES:
    However, it had no touch upon boot, tested the screen on a good board and checks out good... after a while, it was acting weird... It powered down on its own and when plugged in it would show the battery dead icon, I tested the battery in another and it had about 67% charged. Then it went from booting to the home screen to now just only hanging on apple logo, but PC detects it and 3utools is asking to unlock to connect, but the iPhone never goes pass apple logo now. 3utools times out after a while, I unplug and plug it back in and it would detect and say swipe to unlock however the iPhone just still stays on apple logo, after a long hang it just powers down. I changed out HYDRA with the battery and power acting weird as a troubleshooting step. New Hydra in place gives me same results currently just hangs on apple logo. Do you think leaving off C2650 is causing this problem or created this new problem?

    I know I still have a no-touch issue once I can get it to boot again back to home screen. unless this no boot to home screen is somehow tied to the no-touch issue

    thoughts?

  • #2
    It sounds a lot like iPhone 7 audio ic mclk line problems, so my guess is that this phone had a drop or bend which caused the NAND short, but that drop also caused other problems--no touch and hang at apple logo. I think looking hard for physical cracks in underfill might be your only clue, otherwise see if there are loose pads under audio ic as in the 7, or another chip with similar loose pads. Let us know what you find.

    Comment


    • #3
      Just a quick update, U6200 USB-PD, I replaced it to see if this could be the issue, however, results was the same. I left it off and tried to boot as well and got the same results. I verified with another board with it off iPhone 8 still boots to the home screen with U6200 removed. This information can be used for later troubleshooting.

      Comment


      • #4
        Ok, so let’s all work together here!
        This week Mark has two 8p with no touch. He realized that diode mode in touch connector was related to home button. Pressure on home button connector and touch came back.
        then he replaced home button connector and—-now boot looping.

        And for me, iPhone X that thinks it has low power showing battery icon. This happened after using iPhone 8/X dcps squid on two different jobs. I think something is up with the squids or charge ports or some part issue during troubleshooting. On one I changed Tigris and it booted today but then returned to same state. I think I am causing this somehow—probably with the squid. Maybe I am touching vbatt to hdq battery data line and frying Tigris.

        gonna check that out next. I will change Tigris and then also hydra.

        if this is the same for you maybe your boot loop is hydra related and needs update after changing hydra again.

        Comment

        Working...
        X