Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

ipad Mini 3 - Itunes recognized and prompts to unlock, but stuck on apple logo

  • Filter
  • Time
  • Show
Clear All
new posts

  • ipad Mini 3 - Itunes recognized and prompts to unlock, but stuck on apple logo

    Ipad mini 3 is being recognized by iTunes and prompts to trust, but I can not trust because the iPad mini stays on the apple logo. I did an update and it went thru successfully but same results. Changed out tristar, twice same results, changed charge port and Tristar again and did a flash with 3utools retaining data, got same results, tried the update again on iTunes still the same. I also tried two separate batteries, same results. All the flash went thru successfully, however, it does not go to the home screen to swipe through Itunes and 3utools recognizes and ask to allow and trust. This issue was exactly the same as my iPhone 8 Post. I guess if I can figure this one or the other one out I could resolve both. Have anyone experienced this before?

  • #2
    I had one like that and I asked customer if I could restore to “prove” that there was nothing to be done. It restored just fine.

    on iPhone 8 is suspect audio ic or some other flex damage that is new. But on a mini I’d suspect nand corruption.

    Unrelated, but I have been trolled by the updates not completing before by wrong passcode. After update “click home to recover data” state —if you enter wrong passcode device will ask for confirmation and then show the progress bar slowly all the way to the end. If that passcode was wrong, it will reboot to the “home to recover” white screen again—ie it never tells you that the passcode is wrong, it just resets back to beginning at the end.