Announcement

Collapse

Announcement

Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: http://forum.mendonipadrehab.com/register to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

iPhone 7 - No touch with front camera and sensor cable connected

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • iPhone 7 - No touch with front camera and sensor cable connected

    Hi,

    I have an iPhone 7 that lost touch functionality over a very short period - 2 weeks.

    Initially, a reset of the phone would restore touch. Now no touch functionality at all.

    I inspected the logic board and no visible water or physical damage. I inspected the front camera and sensor connector on the logic board but can't find any damage or disconnected pins.

    I disconnected the front camera and sensor cable and the touch would work normally.

    I ordered a replacement front camera and sensor cable and still, when connected the phone would have no touch.

    The new front camera and sensor cable were merely connected to the logic board socket without being attached to the LCD assembly with the earphone speaker.

    Please if you could advise where or what I could look at.

    Regards

    Spidey



  • #2
    Are you saying that touch works fine right now as long as fcam assembly is not present?
    If so, your next step is to see if the problem persists with a known good fcam assembly—not new—known good that is from another iPhone 7.

    fcam assemblies are often bad/defective when sold as a replacement part.

    Comment


    • #3
      Hi Jessa,

      Thank you!

      Yes with the fcam not connected touch is working perfect!

      I will try with a known good assembly and revert back.

      Regards

      Spidey

      Comment


      • #4
        Hi Jessa,

        Some feedback for what it is worth, the problem was solved by installing a new LCD assembly. Still a bit strange was that the fcam was the same one when touch didn't work.

        But everything is working and that is the most important.

        Regards

        Spidey

        Comment


        • #5
          Yes, Rule #1 foxes more problems than anything else!

          Comment


          • #6
            I know this is an old post but I would like to add my experience too

            Ip7p. Earspeaker was not working after screen replacement. They thought it was the flat itself and 3 different moronic technicians tried different flex and speakers. It ended up to me as "please replace camera flex fpc

            Of course it was None of that bullshit but a failing audio ic ball. Reballed with jumpers and I thought I was done

            Nope. The phone behaved weirdly. At first it rebooted a couple of times soon after turning on then it seemed stable. Making a call tho showed that the speaker was not working and two times out of three it would turn on without the touchscreen being completely unresponsive.

            I replaced the flat and.. Bootloop... It would bootloop a couple of times and then stay on for no longer than 30seconds or it would bootloop straight away if you tried to answer a call..

            What did solve this? The good old known good whole iPhone assembly. Putting the board into a known good iPhone would make it work seamisly.. After a bit of swapping components it turned out that it was the combination of the customer lcd and good camera flex causing issues..

            The customer lcd would work fine with a bad flat or no flat but 2 times out of 3 the touch would not work.
            It would cause reboots and bootloops with a good oem flex.

            New flex and new LCD solved it all.



            It is still a mistery to me of why but I think it is interesting if anyone get the same behaviour to always first try a whole iPhone assembly + lcd. Or it turns quickly into a rabbit hole!
            Last edited by DocVolt; 11-18-2018, 12:37 AM.

            Comment


            • #7
              I have a case now in front of me that is the same. It is a freshly done DIY housing swap that needed tristar. After tristar changed and testing in custom housing I get weird behaviors, including no touch, that all seem to be related to the custom housing and it’s crappy parts.

              Comment

              Working...
              X