Announcement

Collapse

Announcement

Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: http://forum.mendonipadrehab.com/register to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

iphone 6 no facetime camera, no earspeaker, no touch id and (reported) slow touch

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • iphone 6 no facetime camera, no earspeaker, no touch id and (reported) slow touch

    hi got an iphone 6 that came in from another shop and they reported no facetime camera, no earspeaker, no touch id and they also said they experienced slow touch screen reaction (never happened to me) it was never worked on before (still original circuit cover adhesive and eveyrthing) so no touchdisease repair happened before. touch id LDO seems to work correctly (1.8v at the connector pin) replaced flat and earspeaker but no change. every filter i checked has continuity. i tried to replace big audio ic (u0900) but nothing changed. what should i look on next?

  • #2
    I would pick one issue and solve it. Let's start with FCAM. Diode mode any line that seems relative to FCAM function (after doing rule number one--confirming that this isn't a parts issue). Then check for the presence of FCAM voltage with fcam present and plugged in and camera app opened and turned to fcam.

    Comment


    • #3
      solved facecamera replacing l1139,

      now remains the problem of no microphone and earspeaker ( vocal memo says no audio device found)
      and no touch id (found a small lsd on the right screwhole, pp3v0_mesa was interupted. fixed that but i still miss pp16v5_mesa. will probably need to replace U1503 right?

      touch id is not inportant now, i would like to solve the audio problem first

      Comment


      • #4
        loud speaker and vibration works fine so AP_BI_I2C1_SDA and AP_TO_I2C1_SCL are ok

        Comment


        • DocVolt
          DocVolt commented
          Editing a comment
          BTW it takes ages to boot. Up to 2 minutes

      • #5
        does audio ic get hot? I prefer to use my multimeter to figure out a fault, but on an older phone like a 6 when it is a low yield repair (multiple issues, has lsd, unlikely to ever work 100% since the fingerprint sensor is likely a home button missing/damaged issue, then I would just change audio ic to rule that out quickly before going down the diagnostic rabbit hole. If not solved, then I would look crisply for technician damage. The fcam filter you replaced doesnt just "go bad" someone had to damage it somehow--however that happened would be a clue. Heat, vs technician knocked it loose. If technician damage, then that combined with lsd would have me looking for missing filters by dock or anywhere that could cause the audio issues.

        Comment


        • #6
          Sorry this one ended up in the drawer for a bit as it is low priority

          I replaced audio ic with a brand new one and the audio recorder seems to work. Actually everything (but touch id) seems to work. The only thing that refuses to work is the earspeaker. Part is good. It has continuity from the gold pins on the flat to the pads under the audio ic (with the ic removed) still refuses to work. So right now I am stuck on no touch id (mesa boost ic is probably dead) and no earspeaker. I want to fix the earspeaker first

          Comment

          Working...
          X