Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

Bootloops on IPhone 6 and 6+

  • Filter
  • Time
  • Show
Clear All
new posts

  • Bootloops on IPhone 6 and 6+


    I have an iPhone 6 and an iPhone 6+ that have exactly the same problem : they “bootloop” if I don’t press the right of the screen.

    I’ve read the whole forum in the motherboard repair section, and I didn’t find anything about this case.

    I’ve restored and upgraded iOS (while pressing the screen - If I don’t press, on uTools it ends up at 20%).

    It doesn’t solve anything: the phone works well only if I put it in “plane mode” with no WiFi and no active code.

    If I try to activate a code (in Settings), then it starts bootlooping immediately.

    And then I have to press again the screen to boot, enter the passcode, go to settings, and put it off. After that I can stop pressing on the screen.

    If I enable WiFi or 3g that’s the same problem : it crashes and starts bootloops.

    I think it’s a common problem on iPhone 6 and 6+?

    (Sorry for my bad English)

  • #2
    If pressing on a part of the screen causes the phone to work properly, it sounds like the pressure is also flexing the motherboard. If flexing the motherboard get it to boot, then you have something damaged / separated on the board itself. What is the history of the phone? Has it been worked on before, seen excessive heat, water damage, bent frame, etc?


    • #3
      What does “activate a code” mean?

      What happens when you have the board out of the frame and just laying on your desk? Does it boot? Does the WiFi chip get hot?

      What is your vccmain diode mode reading?

      what is the full history of these devices, when we’re they last working normally and what happened since then?


      • #4
        The iPhone 6 belongs to my daughter and I think she puts it in her pocket when she sits down, so I think it has been bent.

        The iPhone 6+ belongs to my cousin and it has been replaced a lot of times by Apple. The last one was ok for 3 months but according to my cousin it stopped working during the night in May or June of 2018 during an automatic update of iOS. She didn’t know that pressing the screen could solve the problem for a while, so she considered the phone was dead (apple replied that this time the 3 months warranty was over for a couple of days). But during the 3 or 4 months she owned it it never fell down and has never been bent : she is very careful.

        For these 2 phones, they never noticed any excessive heat, and no water damage.

        For the code, I was talking about General/Settings/Touch ID and passcode/Turn passcode on or off.

        I haven’t disassembled the motherboard yet and I will check if it boots when it is alone, VCCmain, the temperature of the WiFi chip, etc.

        But I can certify that both can charge and work properly when they are on airplane mode with passcode off.

        When I put a passcode on it crashes.

        When I put the WiFi on, it works properly until it goes into standby mode, and then it never wakes up and starts bootloops.

        That’s the same with 3g or 4g. If cellular data are off, it works properly (I can use phone calls). With 3g or 4g, bootloops after going to standby mode.

        I had found another way to avoid these crashes : I had deactivated the standby mode. So the screen was always on (the battery was draining faster...) and so my daughter managed to use her phone normally during 4 days.

        I hope it answers some of your questions. I will disassemble the phones soon, but maybe a lot can be said before that?

        I had read someone saying that it could be a bad communication between Nand and EEPROM : sometimes the iPhone 6 wants to speak with EEPROM and doesn’t manage to do it, so it crashes.


        • #5
          All repairs start with rule number one. you don't have a board problem until you know you don't have a parts problem. Get a known good housing and make sure this isn't just bad parts.


          • #6
            You’re right, that would be nice, but I’m not a professional and I only have these 2 iPhones 6. I really don’t know how to find someone who would let me disassemble his functional iPhone 6 to make some tests.
            That’s why I’m trying to find an explanation for these strange and similar behaviors of the 2 iPhone 6, before buying new parts or unsoldering components.
            But I agree with you, it would be much more comfortable if I could be 100% sure that the problem is in the motherboard.


            • #7
              OK i followed some advices found on the internet, and I tested R0316 and R0317.
              Everything is ok with SDA near R0317 (0,47V in diode test), but SCL is wrong near R0316 : 0,6V to 0,7V in diode test, instead of 0,47V required.
              When I press the CPU it is ok (0,47V).
              When the CPU is cold it also gets back to the good value, but not when it is hot.

              So I think I’ve found the problem.

              I’ve seen lot of tutos about the way to dig into the CPU in order to connect a wire directly to AR31, have you already done this strange repair?


              • Jessa_the_Professa
                Jessa_the_Professa commented
                Editing a comment
                I think you should do rule number one. "You don't have a board problem until you know you don't have a parts problem"

                You are describing an unusual presentation in two different phones--and you still have the boards in those same housings. With no water damage, and a history of rear pocket carrying what is the most likely cause of the problem? Some kind of bend.

                From what you describe here, you have confirmation of mild bend that is causing poor connection at CPU of one line. That line may be unrelated to the problem you have here---we know that high resistance at the EEPROM resistors will cause error 9 on restore/update. We don't have any evidence that loss of signal on that line would correlate with wifi/rf functions that you describe here. "Phone works but only in airplane mode" I think that considering drilling into the CPU to run wires to solve a resistance problem when you haven't even ruled out that this problem could be solved with a straight housing is very very very premature.

                My advice---if you want to do microsoldering repairs, then invest in basic microsoldering equipment and general cell phone repair equipment and parts. Otherwise, find a shop that is willing to rent some equipment and sell parts to you.

                The next step for these phones is to put them in a STRAIGHT housing that has not been bent just to see if that helps the board sit in its natural flat state and cures your flexion damage. If not, then yes carry on.

                And to answer your question--yes we have done this repair many times, but only on error 9 phones.

            • #8
              I’ve tried to restore it with iTunes and it says « error 9 », and with uTools it stops at 20%. Unless I press the CPU.

              Concerning the WiFi or cellular datas on/off and the airplane mode : when airplane mode is on or cellular data is off the phone keeps working properly.
              If I turn the WiFi or the cellular datas on, it crashes. I also tried to turn the cellular data off for every app, and a few KBytes are used by « system services » just before the crash.
              I’ve spent a couple of hours studying it, it depends on whether the passcode is on or not. With no passcode, no crash.

              And of course if I press on the screen it doesn’t happen.

              It looks like the phone tries to connect to a server to check some datas.

              I have disassembled the motherboard to make the diode tests on R0316, so it was not bent anymore and there were no other parts connected to it.

              So I really think now that there’s a board problem.

              Tell me if you think that I’m going into a wrong way.
              Last edited by JoeBouvier; 11-13-2018, 05:44 AM.


              • #9
                I think you have bend, and you have the cpu joint open at the eeprom resistor, but likely also somewhere else. You could try the cpu wire fix, it is fun to do. My strong advice is to get some donor phones. For the CPU job you should absolutely drill on a practice board first to see how far down you should go and to see exactly which microvias in the cpu map to the resistor.

                But first, if you want to be practical—if I were diy I would see if I could shim the board in a straight housing to put pressure in the opposing position of the bend to just be able to use the device. If not, then I’d consider it a donor phone and have fun drilling cpu.