Announcement

Collapse
No announcement yet.

iphone 7 restoring VCC MAIN cap on boost circuit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • iphone 7 restoring VCC MAIN cap on boost circuit

    Just an example of (my) technician f**kery. This cap somehow became dislodged. A little birdy is telling me I'm not going to get away with leaving this guy off. Clearances are tight. Have tried using a 1mm BC tip and a J tip to tin the pads without luck. Can't get my Hakko micro tweezers in there properly and even then that cap is too big for getting back on with hot tweezers anyway.
    what's on the other side? CPU!
    Only other solution is to use hot air and heat sink CPU with a coin?.
    Attached Files

  • #2
    Thats a cap on VDD_MAIN, there are ALOT of tjose still on the board... Not the best ppace, but surely will work without that, reliably

    Comment


    • #3
      Let's talk about order of operations. How important is replacing that cap in the grand scheme of this phone ever working again? Pretty far down or not even on the list.
      At the top of the list is the damage to resistors and filters on the right side of audio ic---get those back and see if this phone will even boot. If you can get it to boot, then replace audio ic with jumper. If it still boots and audio works and you have baseband, then you can decide if you want to strategize how to replace a missing boost cap. Definitely not something to worry about for some time, and maybe never. This phone will need a lot of restoration before you get to that point.

      Comment


      • #4
        Update. Firstly using Hot tweezers, I restored the components that were dislodged during Audio IC removal(this went quite well). Next ... decided to clean up flux around caps near DC boost IC and two more came up whilst trying to remove flux from between components with a fine tweezer tip. I was astounded at how easily they came up - I was not being forceful - a hard lesson learnt. Tight clearances, made restoring these caps extremely difficult. I refrained from using hot air and tried fluffing the pads using hot tweezers and a 1mm iron tip(the 1mm tip proved way too huge) instead but after some time trying decided to give it up so went ahead and jumpered the C12 pad and restored Audio IC(sorry forgot about the advice to see if the phone would reboot before doing this). I went ahead and reassembled the phone(minus the sensor connector which I tore). Now, on DC Power Supply, 0mA before prompt to boot. Ok. On Prompt to boot current draw rises up and down from 20mA to varying values in between up tp a maximum of about 230mA ( the first time I did note it rose to 600mA for a split second) where it remains for a number of seconds .... current draw then drops to 0mA, the screen goes off(phone shuts down?) and the process repeats. Always cuts off around the 200mA point. Have I fried the CPU?
        Attached Files

        Comment


        • #5
          Eliminate variables.
          Take the board out of the housing (putting it in the housing would be dead last on your list of order of operations)
          You want to constantly be "proofing" the board---making sure that it still boots after each microsoldering change that you make.
          From here you need to go back---get rid of any change that you made that is not necessary for the board to boot. That will depend on what iOS the phone is on. If it is recent--iOS12 or 13 then it will boot without audio ic

          Try to boot the board with just dc power supply and screen--nothing else attached so that you are eliminating variables. Prompt it to boot with tweezers at the power button connector. Show us a video of what dcps shows.

          Comment


          • #6
            Ok connected motherboard to DC power Supply. Boots to the Apple logo... stays there... until current draw drops to zero for a brief second... then boots to the Apple logo
            Link below shows current draw ( I doubled the video speed to cut the playtime to a bit over a minute)

            https://youtu.be/_TAHRRDV4xI

            Comment


            • #7
              Took off the Audio IC. Initially demonstrated same behaviour ie incremental rise to 200mA until on the last bootloop cycle Slight difference I noticed the current draw rose up to 250mA and stayed there until the current draw dropped to zero, then rose to 180mA. Looked at the screen and noticed phone booted into restore mode. Disconnect the power and on repower up of DC power pretty much immediately rises to 180mA and stays there until I disconnect the power. Yep stuck on restore mode.

              Comment


              • #8
                BTW it took me 22 seconds to hot air off the Audio IC at 360 degrees C 120L airflow 7-8mm nozzle. I didn't heat sink NAND.(I have a video if you think its relevant) Surely I wouldn't have destroyed NAND?? CPU??

                Comment


                • #9
                  You have a board that is autobooting to recovery mode. Next step is to release it from recovery mode and see if it automatically returns or not. Boot with DCPS and a dock--connect to computer, use exit recovery mode from 3utools or iReboot or similar.

                  You seem really worried about heat--I think you the worry is creating more problems for you than the heat. Look at the pictures of this board--this is a lot of tweezer/hand damage. It is impossible to "blow" components off the board with hot air---they only come off when we touch them while hot. I see exposed ground, a lot of components have been nudged, some are now broken from efforts to fix other missing compoents, or need to be reseated. All of this comes from "handling" Work on a low value practice board and just spend some serious time moving components around with hot air until it feels extremely natural.

                  We don't know why this board is auto-booting to DFU, however far and away the top of the list is "problems created from handling while trying to fix missing/loose components" and very low on the list is "overheated chips"

                  Report back on what happens when you release this board from recovery mode with only dock/dcps attached.

                  Comment


                  • #10
                    Clicked the Exit Recovery on 3uTools
                    Wasn't able to release the board from Recovery mode.
                    Please see attached screenshot.
                    Was going to follow the 3utools instruction....
                    Flash the device if device automatically enters recovery mode after you exit recovery mode.
                    Had the latest version of IOS downloaded but after disconnecting and reconnecting
                    Short the Power pins.....
                    Now the phone won't even boot. Increments up to 110mA drops back to 80mA then 0.
                    I can only guess what I did to cause this?
                    Attached Files

                    Comment


                    • #11
                      You'll see from my previous post I put the board in the frame to access the charge port flex! maybe not a great idea. For all I know at some stage something may have touched what it shouldn't and BAMM! Right now I'm wrestling with iphone disassembly/reassembly... the convolution of tiny screws with different heads and of all shapes and sizes and the tiny intricate parts…. why don't they make them like Samsung? A Free floating board in a frame... what's so bad about that Apple...huh?

                      Comment


                      • #12
                        You need to eliminate variables. Pretty sure I've said this before.

                        1.) Build basic skills. Leave the microsoldering and this board alone until "screws and glues" are second nature easy jobs. Don't touch this board again until you can disassemble the logic board from an iPhone 7 in less than 2 minutes, and have all the screws memorized.

                        2.) Stop using the phone housing as "known good parts" Your main goal is eliminate variables. Especially if you are struggling with connect/disconnect do not use the housing for a charge port. Get a charge port, battery and screen that are known good.

                        3.) Recovery mode, so you have taken the device out of recovery mode--now this board is going 0-100ma--0--100mA. This is what a phone will do with CPU output signalling problems from a loose resistor or bridging under a chip that talks to CPU, or damaged/missing sdram, or damaged power to the CPU, possibly from loose CPU coils.
                        You still need to eliminate variables--show us a picture of the audio ic off the board, after you have put it in ultrasonic to clean flux so we can evaluate the audio ic area. Then you may want to consider removing the top CPU shield so that you can look for signs of too much heat at components around CPU, or not. Be careful when taking off this shield. It will not pop off by itself--use heat and your experience of how much time to heat the shield, and then (working quickly) take away the hot air and use a tool to lift the hot shield off.

                        Comment


                        • #13
                          Picture of board after Audio IC removal
                          Attached Files

                          Comment


                          • #14
                            I see exposed ground near your C12 jumper---what does your multimeter say about I2S_AP_TO_CODEC_MCLK compared to known good?
                            Can you confirm that I2S_AP_TO_CODEC_MCLK isn't bridged to CODEC_RESET_L

                            Are you sure that you don't have physical tweezer damage to U3601 homer chip, or accessory boost chip?

                            I would remove the C12 jumper and clean it up--making sure that nothing is touching ground or a neighbor. Then if the device is in the same state I would pull CPU shield to have a look for heat.
                            If I didn't see heat then I would use my finger to apply pressure to CPU/coils/BBCPU to see if that changed anything. If not change, then I would see what happens if I try to restore.

                            Comment

                            Working...
                            X