Announcement

Collapse
No announcement yet.

iPhone 7 audio IC repair, intel board

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • iPhone 7 audio IC repair, intel board

    Hi, first of all i would like say sorry for my english. Hope, you will understand me
    I would like ask about iPhone 7 audio IC repair. I have many motherboards on which i provided audio IC repair. Im using preheater PPD120 with 130°C (calibrating based on melting solder iron temperature). Audio IC removing with soldering station like on this video: https://www.youtube.com/watch?v=AHJSsx5lsSE (im using this method for preventing overheating motherboard and damage baseband IC connection). Than jumper wire, clean, UV mask etc..new balls on original audio IC. Than attached back with Quick 861D hot air station (330°C air flow 43). This will take about 10 seconds to melt solder. After this process im waiting to cool down motherboard. Test - ok, audio IC working, signal ok (modem firmware OK). Many customers comming back after 2-4 weeks due to no signal. I know its common issue - baseband problem. It sounds like easy answer - just reball baseband modem IC and it will be back again. But sometimes it help and solve the problem but sometimes no.
    Question after this long description is - is there some technics, how to diagnose, if there is problem with baseband IC, BBPMU or somwhere else?
    If you think, i want to know a lot of informations and you dont want to tell me details, i can understand it but i will be very thankfull for all comments
    All motherboard are intel boards. I think, i didnt overheated motherboard (or maybe yes? but many technician working with the same settings of temperatures).
    Thank you all again




  • #2
    Everyone is different, but your approach may be too low heat.

    i did audio ic yesterday—I used 410-430C, 70% air. It takes only a few seconds to come off with hooked tweezers. Then jumper and reball with 183C paste. Sometimes I use 138C paste. Then I put the chip on using preheater and some hot air maybe 350C—it goes on in just a few seconds.

    if you had modem before the job and then not afterward, it is difficult for there to be any other explanation other than baseband cpu floating from heat.



    Comment

    Working...
    X