Announcement

Collapse

Announcement

Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: http://forum.mendonipadrehab.com/register to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

iphone 7 no power up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • iphone 7 no power up

    iphone 7 No power up

    Out of the frame with known good battery, charge flex and screen
    1. USB - 0mA current draw no boot
    2. DCPS - 0mA before prompt to boot
    3. DCPS - prompt to boot goes straight to 200mA - stays there
    My thoughts. Assume charger damage. Change Tristar?

  • #2
    I asked the person who confirmed that they were the original owner whether the phone had ever been exposed to liquid/water damage. They said no.
    The phone doesn't have any evidence of prior open ups/repair but when I took off the heat stickers I see some of the ICs have a rainbow tinge to them. This does not look normal.
    Has anybody seen this before.? Is it significant?

    Comment


    • #3
      When I lightly rub my finger over the surface of the IC, or gently run my tweezers (NOT scrape!)along the surface of the board. See picture.

      Comment


      • #4
        The rainbow coating is a normal artifact that you see now and again. It doesn’t mean anything. Go ahead and rule out tigris then tristar and report back.

        Comment


        • #5
          hello there, hello Jessa and all.

          I saw it before twice. It's like contact spray. Possibility to wash by alcohol. It makes a electrical film improving conduction, often for quick repair of joining components splits. (made by foxconn, used for fresh, problematic mainboards). Second time, some magican from LA used it on complitlly sea water damaged board. It looked like brand new and that rainbow :-) , but after cleaning - lots of coroded, grey caps. Everywhere. Mainboard - no power, no life, nothing. Just 3.8V on vcc.

          Comment


          • #6
            15/10/2020

            Replaced Tristar
            1. USB - 0mA current draw - boots? to Apple logo - logo gone(half a second) - boots? to Apple logo
            2. DCPS - 0mA before prompt to boot
            3. DCPS - prompt to boot, this time climbs to 200mA, then drops back to zero. If I keep the tweezers applied. It repeats the climb, drops to zero over and over


            Replaced Tigris

            Behaviour unchanged

            Comment


            • #7
              Woops I was supposed to change Tigris FIRST, then Tristar?

              Comment


              • #8
                Yes—change tigris. That is the common fault for iPhone 7. Then see if the problem is that it is autobooting to DFU by checking to see if the computer detects it

                Comment


                • #9
                  Still caught in a bootloop, hung on the Apple logo
                  1. USB - Behaviour unchanged
                  2. DCPS 0mA before prompt to boot. Prompt to boot current draw climbs from low mA to 150mA, 200mA drops back climbs to 320mA, drops back climbs to 400mA even up to 500mA

                  drops down to low amps, parks at zero for an instant then repeats



                  Cannot get into DFU mode - not even in Force DFU mode ie 1.8v into the FORCE_DFU testpoint.

                  Forced parts for testing board into DFU mode(to make sure I was doing it right!) I was so the problem is with this board.

                  I replaced TIGRIS (again) No change.
                  I replaced TRISTAR(again) No change

                  I remember when I first tested this board it was completely dead (via USB)- wasn't even booting to an Apple logo.
                  When I replaced Tristar - it started booting to an Apple logo. And that's as far as I got.
                  I don't know where to go from here.

                  Comment


                  • #10
                    Great, you've changed tigris and tristar to rule out invisible electrical damage. Now with that done, you need to ask the phone to restore. IT WILL go into DFU mode.
                    Forget about all the "volume up then down power button, etc"

                    Disconnect battery, press volume down, plug in battery. Connect usb known good charge port to computer.

                    Force_DFU method = inject 1v8 into force_DFU pin, then connect battery and known good charge port and plug into computer.

                    If you're not able to use either method to get the phone in DFU, then troubleshoot your charge port and the connection of your charge port to the connector on the board. Then check your tristar job. A board that is boot looping like you describe here will always go into DFU mode.

                    Comment


                    • #11

                      DCPS. I (accidently) went past 4.2v put 7v through the battery line for a couple of seconds.
                      Now got 30mA before prompt to boot. Decided I must have blown the mosfet.
                      Replaced the mosfet and Tigris. Now I get 270mA before prompt to boot.
                      At this point I decided to do a continuity test firstly on the VDD_MAIN which tested OL. Then I tested the battery line which also measured OL. I thought current draw before prompt to boot meant there is a short on either the main power rail or the battery rail. Now I'm confused.

                      Comment


                      • Jessa_the_Professa
                        Jessa_the_Professa commented
                        Editing a comment
                        I'm not sure what happened to my comments on this post from yesterday, so I will re-post in case you didn't get to see them.

                        Re: Accidentally injecting high voltage. I'm sure you've learned the hard way, but this is exactly why we always set DCPS first while disconnected, and THEN attach it to the board.

                        7v may be enough to damage anything that is facing batt_vcc and vcc_main. All the capacitors on that rail are rated for 6.3v max and the chips for less.

                        Re: You had 30mA before prompt to boot---this means you have electricity LEAKING TO GROUND. That can't possibly be the mosfet, because the battery/main mosfet has no path to ground. That doesn't mean the mosfet isn't damaged, but if it is damaged that is not part of why you have a current leak to ground

                        You replaced the mosfet, and now you have 270mA leak to ground. This is still a leak to ground somewhere on a line that is connected to batt_vcc.

                        Re: Continuity testing for short. This is not how we test for short. ONLY a FULL short will declare itself when using continuity testing. A continuity test will just test to see if there is 100ohms or less between the probe and ground. If so--beep, otherwise no beep. HOWEVER, we have some lines like PP_CPU that NORMALLY have 100ohms or less to ground but are not short---these will always beep to ground. AND we can have a partial short on main, which may reduce the resistance from Mohms to milliohms. That's a huge leak, but it will not "beep" short in continuity mode.

                        ALWAYS USE DIODE MODE (or resistance to ground) and COMPARE TO KNOWN GOOD to test for short in iPhones.

                        Re: What line was short?
                        Your short was probably on Speakeramp1_LX. This line is a branch from batt_vcc and would show current draw when you connect batt_vcc to dc power supply.

                    • #12
                      I can't understand any of this. I connected up power from DCPS thru the battery connector … get 250mA -before prompt to boot and when I applied power and touched the board the area around Tristar was getting very hot. I disconnected cooled, applied freeze spray and tried again. U3402, the IC beside Tristar, starting in the Left hand top corner to the entire IC heated up before anything else. Tried later - exact same behaviour. I'm still trolled by current draw before prompt to boot and not picking up a short on either the main power rail or the battery rail. I also measured the seated resistance on both which measured close to what I measured on my test board. I'm now just making stabs in the dark.

                      Comment


                      • Jessa_the_Professa
                        Jessa_the_Professa commented
                        Editing a comment
                        Great--here you learned to measure for short with straight up resistance, and you've ruled out battery_vcc and vcc_main. So what is left? Anything that is a branch from those lines, like vdd_boost, or speakeramplx, or backlight anode---these are all lines that are possible to show current leak before prompt to boot when short, but are not batt_vcc or vccmain.

                        The most likely reason that speakeramp1_lx is short is damage to the chip itself. Remove the chip and see if the short goes away.

                    • #13
                      I stabbed in the dark, removed U3402 250mA before prompt to boot gone. Now 0mA before prompt to boot, bootloops normal through DCPS as before. I wont replace U3402 yet I'll leave U3402 off for now and replace it after I solve the booting issue. I've verified on another working board that my replacement Tristar was actually a dud. Tested another one working fine. I'll try it on this board and see how I go.

                      Comment


                      • #14
                        I know this Tristar works but Tristar doesn't want to align. It ALWAYS reseats to this skew position. I can't understand it. Phone still wont boot through USB

                        Comment


                        • Jessa_the_Professa
                          Jessa_the_Professa commented
                          Editing a comment
                          A chip solders ITSELF on the board, based on the properties of cohesion and surface tension. If you put two drops of oil next to each other and gave them a tiny vibration--they would connect. This is how tristar attaches to the board. YOU don't "TELL" the chip where to go, it goes where surface tension and cohesion pulls it.

                          Your only job is to make sure these forces can work----any "debris" will act like a speed bump so that the liquid balls and liquid pools on the pads can't connect together. Make sure you have a clean dance floor.

                          In my experience, I've never had a "dud" tristar that was in a strip of new tristars. It sounds like you may not be using new tristars? You do not want to be reballing old tristars--that's a different skill and adds a variable that you don't need right now.

                          Put a new tristar on, after making sure you have a clean dance floor. Show us a picture of the board with tristar off and then on. It will go where it is supposed to go.

                      • #15
                        Always resets to this skew position. Frustrating!

                        Comment


                        • Jessa_the_Professa
                          Jessa_the_Professa commented
                          Editing a comment
                          Cut that bracket from around tristar and remove it. You have no idea what is going on under the bracket--this chips up there could be nudged or bridged, and therefore not delivering the accessory voltage you need for tristar to work. You can't see at all from this picture.
                      Working...
                      X