Announcement

Collapse

Announcement

Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: http://forum.mendonipadrehab.com/register to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

iPhone X no boot

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • iPhone X no boot

    Hi everyone, my name is david i'm from Portugal and new on this forum, i have just one year of experience in micro soldering and repair but want to learn more ✌
    and will need your help.

    So here i go …

    Model: iPhone X 64gb ( intel )

    I received an iPhone X from a customer, when i received it was in boot loop apple logo but after few attempts to switch the phone on … nothing more happened, like dead phone ( no more apple Logo ).
    - Disconnected the connectors one by one and tried to switch on the phone to checked if wasn't a connection but nothing change … no boot.
    - Take out the board and was immaculate ( never touch ).
    - Connected the board to Power supply, no current leak and ckecked the VCC_MAIN, VCC BAT and value was normal.
    - After that i connected the board to power supply but with iboot power universal and tried to switch on the board and on iboot i saw that:
    current jump immediately to 0.890A and go to 0A in a second and do that in loop ( again and again / infinity loop )

    Someone already had this issue or can help ?

    thanks
    #staysafe

  • #2
    Sometimes iPhone X does not like to boot from DC power. Check to make sure it does not boot with good battery and good screen and good dock outside of the frame. Most common problem is bad parts.

    if not, then check common spot of shorts on 3v0 nand rail and other nand power rails near edge of nand

    Comment


    • #3
      Hi Jessa ,

      ok i will try tomorrow and let you know the results.

      Thanks
      #staysafe

      Comment


      • #4
        olá ,

        so i tried to boot it with new battery , good screen and new dock … but nothing change .
        so i separate the upper and lower layer , when i connected the upper layer to the power supply and powered, happened this:
        Current jump to 0.130A and stay stuck on this value …

        but i don't know if is significant because i heard iphone X intel board can't boot up if the upper and lower are not attached … is true ?

        kind regards

        Comment


        • #5
          That is normal for the intel top board. Put on a charge port—it will be detected by iTunes. Sometimes the problem on iPhone X is corrosion between the top and bottom board, so next step is to put the board in the isocket with a known good bottom board and see if it boots. If it does, then try it’s own bottom board to see if there is a bottom board problem or not.

          Comment


          • #6
            ​​hi,

            So here the news about the iPhone x board … and i think i messed up and news are not good

            I made all the measurement again ( logic board separated from signal board ) :
            1) PP_VCC_BAT — OK
            2) PP_VDD_MAIN — OK
            3) PP_VDD_BOOST — OK
            4) 1V8_ALWAYS — OK

            Powered on the board … ( attached to the power supply to see the consumption and voltage ) …
            everything was find … consumption up to 0.144A and stay , só started to make voltage measurement to PMIC ( U2700)

            and i found those voltage:

            1) PP_CPU_PCORE — OK — 0,70V
            2) PP_GPU - BAD — 0V
            3) PP_SOC_S1 — OK — 0.795V
            4) PP_1V8_S2 — OK — 1.792V
            5) PP1V8_IO — OK — 1,792V
            6) PP_1V1_S2 — OK — 1,096V
            7) PP0V7_VDD_LOW_S2 … HERE I THINK I MESSED UP ! ( so couldn't continue checked voltage form other lines )

            So, to check PP_0V7_VD_LOW_S2 we have just one capacitor ( C1750) under shield … and … i remove the shield with hot air 😥
            NAND very close but protected it … but i completely forgot to check the other side before removed it … but i removed it 🤨 and in the other side you have … CPU !!!
            and continued straight away to remove the other shield beside …. but after removed it with air too … that i remembered …. OH NO OH NO NO NO NO — PMIC ON THE OTHER SIDE !!!

            i powered off the logic board and powered on again … but now its happening that
            current Jump around 0.450A / 0.600A and go to ZERO … in loop ( pics attached )

            Click image for larger version

Name:	IMG_6977.jpg
Views:	36
Size:	2.13 MB
ID:	8025


            in DIODE MODE i have those results

            1) PP_CPU_PCORE — 012
            2) PP_GPU — 003
            3) PP_SOC_S1 — 034
            4) PP_1V8_S2 — 325
            5) PP1V8_IO — 059
            6) PP_1V1_S2 — 066
            7) PP0V7_VDD_LOW_S2 — 370
            8) PP0V8_SOC_FIXED_S1 — 000
            9) PP_CPU_SRAM — 376
            10) PP_GPU_SRAM — 272
            11) PP_DCS_S1 — 397
            12) PP0V6_VDDQL_S1 — 195
            13) PP_CPU_ECORE — 039
            14) PP1V2_SOC — 000
            15)PP1V2_LPADC — 347
            16) PP0V9_NAND — 409
            17) PP3V0_NAND — 374


            So what do you think it can be ? CPU 🤨
            ​​
            Kind regards.
            #staysafe

            Attached Files

            Comment


            • #7
              I think you should have followed instructions. You can scroll up and see that my advice was "next step is to put the board in the isocket with a known good bottom board and see if it boots."

              Most likely there was nothing wrong with this top board, it was doing exactly what an Intel top board does---consumes 100mA and sits there because it is in DFU mode automatically.

              With iPhones, less is more. We use the tools of experience like a physician, not "measure all the things" like an engineer. We do not pull shields off on iPhone X unless there is a good reason. Why? Because of exactly this. You had no reason to remove shields, and it is a dangerous operation that we do not do to "take a look"

              What is wrong with the board now is heat damage at underfilled chips. The problem is wherever you can see heat on the board--look for tiny solder balls at edges of components. Look for heat. I think this board may be better purposed as a donor board now.

              Comment


              • #8
                Hi Jessa ,

                i followed your instruction , sorry to forgot to mentioned it , i put the board in the socket and try to boot it liked you said but nothing change …

                ok i will check for solder ball or signals of heat … but do you think it can be more PMIC or CPU ?

                thank for your help.
                kind regards.


                Comment


                • #9
                  If original top board did not boot up in iSocket with original bottom board, next step is to see if it would boot with known good bottom board. After that, next step is to force it to connect to iTunes and restore.

                  The top board has been heat damaged. The problem is where the heat was—where do you see solder balls popping out of underfilled chips?

                  Comment

                  Working...
                  X