Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

iPhone 8 Plus No Boot

  • Filter
  • Time
  • Show
Clear All
new posts

  • iPhone 8 Plus No Boot

    Right this one might be a strange one but i'm hoping someone has seen an issue like this before and can point me in the correct direction!

    I got an iPhone 8 Plus in with no power - it wouldn't take any power from USB, no DFU mode and it wouldn't boot on DCPS. Tristar tester said faulty tristar so I replaced the Hydra IC thinking it was an easy one to rule out. After replacement - phone working normally - charges, boots up, talks to itunes no issues. I've handed it back over to customer who has brought it back a week later with a no boot issue - thinking maybe I didn't fit the Hydra IC properly I went ahead and reflowed it onto the board and phone is working again! Unfortunately 5 minutes later the same fault has come back again - no boot although it does pull around 1.3a on USB ammeter when connected to charger. I've replaced Hydra IC again with another one just to rule out a faulty IC but the behaviour is same the phone won't boot. On DCPS the board goes up to 0.079 current draw when prompted to boot and stays there.

    My thought process is at the moment that I must have inadvertently heated something else on the board when replacing Hydra which fixed the boot issue - but I cannot figure out what that could be! I initially thought maybe NAND but I am very careful to direct heat away from NAND when doing any kind of board work near it and also I covered the NAND to further reduce the risk.

    Should also add i'm testing the phone in a known good housing to rule out housing issues but I have also tried the logic board bare on the table with just the DCPS connected and it still doesn't boot!

  • #2
    8p with intermittent no power is usually cpu related. Press on the cpu and it will likely boot. Sometimes it is one of the cpu coils—you can voltage test and see if you can find which one is missing/low voltage.

    Hydra is an unusual failure for 8p


    • #3
      Yeah I don't see faulty hydra much if at all on 8/8 Plus although I have seen it a few times on X before.

      I've tried pressing the CPU and it still won't boot, i've checked each of the coils and with the exception of PP_GPU_SRAM all of them are giving 0.8v to 1.2V after prompt to boot. I'm not sure if missing PP_GPU_SRAM would cause a complete no boot issue though!


      • #4
        What does it do on DC power supply?