Announcement

Collapse

Announcement

Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: http://forum.mendonipadrehab.com/register to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

iPhone 8 Looks Like Fully Shorted But Cannot locate short

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • iPhone 8 Looks Like Fully Shorted But Cannot locate short

    So i've got an iPhone 8 on the bench today which is proving to be a royal nightmare. We have changed the screen on this device a few weeks back and I can tell you it was very badly smashed but the phone housing was still in good condition and the back was ok. Device was working fine for weeks after this and came in this morning with no power.

    Doesn't draw any power on the USB ammeter, took the board out and tried to boot it on DCPS - as soon as I connect the DCPS to the battery port the DCPS shuts off as there is too much current draw which made me think - probably PP_VDD_Main short. Got my multimeter out and checked PP_VDD_Main - not shorted, PP_VDD_Boost - not shorted, PP1V8_IO - not shorted, PP3V_NAND - not shorted, PP1V8_S2 - not shorted, PP0V9_NAND - not shorted. I spent a long time and couldn't see any of the normal lines shorted, given it felt like there might've been some heat coming from the CPU shield when I had it hooked up I removed this shield and checked around CPU - again couldn't find any shorted lines. Connected it to DCPS again and this time no short? Prompted to boot and it looked like it was booting normally (didn't have a screen hooked up just board on desk connected to DCPS). Left it for a minute and then connected it to DCPS again and short is back again - this board is driving me mad.

    My only thought is that the heat I used to remove CPU shield must've fixed something temporarily but I wouldn't know where to start in what got fixed, only thought I had is there might be a break somewhere either inside the board or underneath either the CPU or power IC. The first thing to get hot when I hook up the DCPS is the main Power IC. At this point though I am thinking to put this one onto the not fixable pile but if anyone has any suggestions or can think of something I may have missed please let me know.

  • #2
    Have you actually seen that vdd_main (or another line) is short with the multimeter? Or just excess current when you plug in squid?

    If the latter—this sounds like a squid problem. They are finicky crappy little products. If another squid lead wires cross or the squid touches the screw bracket it would behave as you describe. Try soldering a wire directly to battery vcc and injecting dc power.

    Prove your short with the multimeter.
    my crystal ball says there is no short, but the board may have some cpu or cpu coils making intermittent contact so the board won’t start in certain positions in the housing when all screwed in. I would want to rule that out

    Comment


    • #3
      Have tried the DCPS squid on another iPhone 8 and it works perfectly. There is no visible short on any of the normal lines that I usually see shorted out but yet when I plug the squid cable in the phone starts consuming 2 amps immediately and the PMIC is the first thing to get hot - verified with thermal cam and freeze spray.

      As an experiment I heated the CPU area of the board very mildly and the phone started up again - got to the passcode screen then it shut off and started getting hot with the power consumption again above 2 amps.

      I'm thinking at this point it can only be either an internal break inside the logic board itself or a CPU problem?

      Comment


      • #4
        You have to know what line is short with the multimeter. Once you see the high current consumption, pull the plug and measure immediately until you know what line is short. Look for hairline cracks in chips--speaker amp near top of the phone, PMIC, etc.

        Comment


        • #5
          Well i had to commit this one to the unfixable pile in the end - I just couldn't find the issue even with pulling the plug immediately and checking. There was just nothing visible anywhere and I did remove all shields to check!

          Comment

          Working...
          X